Sunday, 9 June 2013

Installing Ignite’s OpenFire and Spark (IM server and client)

When testing HuBot, I needed an IM server and client

Since the HuBot install article that I was following recommended OpenFire and Spark, I decided to give it a test drive.

Here is how I installed and set it up on a local VM.

The first step was to get OpenFire from the Ignite's website:

image_thumb[24]

which I did using this O2 Platform script:

 image

... that when executed downloaded the zipfile, started the openfire.exe and opened the default browser at localhost:9090

image_thumb[23]

I then configured OpenFire to use an Embedded Database

image_thumb[25]

... to use the default profile settings:

image_thumb[26]

... and to use this default admin account:

image_thumb[27]

Which completed the setup:

image_thumb[28]

... with no errors in the OpenFire popup process

image_thumb[35]

Next I used to login page:

image_thumb[30]

... which didn't accept the email as username (see above), so I had to use admin

image_thumb[31]

... to login and access the admin interface:

image_thumb[32]

As per the HuBot Install article, we should create a couple accounts and a room:

image_thumb[36]

So, here is the developer account:

image_thumb[37]

... here is the hubot user:

image_thumb[39]

... and here is the hubot room:

image_thumb[41]

With the OpenFire IM server up and running, the next step was to install the Spark IM client:

image_thumb[42]

Which I did using this script:

image_thumb[45]

... which downloaded the installer

image_thumb[43]

... executed it

image_thumb[44]

... and launched it

image_thumb[46]

Using the developer account previously created, I was able to connect to the OpenFire server:

image_thumb[48]

Here is the Spark post login UI:

image_thumb[49]

Here is OpenFire's Client Sessions page (showing the logged in Spark user)

image_thumb[50] 

Finally, to  access the HuBot room we previously created, I clicked on the Conferences tab

image_thumb[55]

Then on the conference.{computerName} option:

image_thumb[54]

... then on the HuBot option:

image_thumb[57]

... and we can see that we have a fully operational client and server IM setup :)

image_thumb[59]
Post a Comment